Elevated response times for DOTS locations identified

Resolved

This incident has been resolved.
Posted Apr 23, 2025 - 17:45 CDT

Identified

We are aware of an issue affecting DOTS retail locations. Stratus response times are elevated and we are working with development to resolve the issue as quickly as possible. Thanks you for your patience and understanding.
Posted Apr 23, 2025 - 11:35 CDT
This incident affected: Services (Stratus).