In store and pay by link payments should be fully recovered. Any issues please contact Ascend Support
Posted Apr 22, 2025 - 08:20 CDT
Update
We are continuing to monitor for any further issues.
Posted Apr 22, 2025 - 08:19 CDT
Update
In Store and pay by link transactions should have significant recovery of services since 4:30pm ET. If payments are unable to process refresh and reattempt as funtionality is improving.
Posted Apr 21, 2025 - 16:42 CDT
Monitoring
We continue to experience intermitent payment processing issues. Please reattempt initating payment if it does not respond at first as they may go through as services are slowly recovering. Do not reattempt completed payments.
Posted Apr 21, 2025 - 12:59 CDT
Investigating
There has been an issue identified with AscendPay payment processing. Currently working with our payment processing partner to identify the extent of the issue and find a resolution ASAP.
Posted Apr 21, 2025 - 12:27 CDT
This incident affected: Payment processing (Klarna - US).