Phone support currently unavailable

Resolved

This incident has been resolved.
Posted Sep 03, 2026 - 18:55 CDT

Investigating

We are currently investigating an issue with the rooting of the incoming phone calls.
Our Ascend support agents are able to answer calls at the moment.
Feel free to email us at help@ascendrms.com if you need support.
Posted Sep 03, 2026 - 17:47 CDT
This incident affected: Phone support (Phone Support - US, Phone Support - CA).