HQ and Trek B2B Login Issues

Resolved

This incident has been resolved.
Posted May 05, 2026 - 17:05 CDT

Identified

We are currently experiencing intermittent outages with our login services, users may be unable to log in or may experience errors. We are working to stabilize the service, thank you for your patience.
Posted May 05, 2026 - 12:42 CDT
This incident affected: Services (Ascend HQ, Retailer Portal) and Third-party integrations (Trek).