Trek B2B System Maintenance
Resolved
This issue has been resolved. Thank you for your patience as we worked to resolve this issue. Please give us a call if you continue to have issues.
Posted Jul 10, 2023 - 09:00 CDT
Monitoring
Due to B2B System Maintenance, order submission and product availability through Ascend for Trek is not currently functional. Orders can still be submitted on B2B or through Customer Care but will be lacking an order number until the issue is resolved.
B2B system maintenance is expected to be completed EOD Sat 7/8
Posted Jul 08, 2023 - 09:59 CDT
This incident affected: Third-party integrations (Trek).