Ascend Pay Payment Issues

Resolved

Our development team has implemented changes based on the information from our third-party processor, and connection errors have dropped. Additionally they implemented shorter wait times for connection issues to reduce slowdowns in case of a future connection event. Terminals and Ascend should be operating normally now, please call Support if you are experiencing ongoing issues, and we thank you for your patience.
Posted Apr 25, 2025 - 09:56 CDT

Monitoring

If you are experiencing AscendPay issues or Ascend slowdowns and you are on AscendPay, we recommend rebooting your server PC and terminals (hold the green button) to refresh the connection. We are working with our third-party processor to resolve terminal connection issues that result in slowness and timeouts as quickly as possible.
Posted Apr 23, 2025 - 19:59 CDT

Update

Ascend Pay services are stabilizing, but we have not yet identified the root cause. We appreciate your patience and understanding as we continue to work towards a resolution.
Posted Apr 23, 2025 - 11:43 CDT

Identified

We are currently investigating continued delays in connecting payment terminals to Ascend, which may result in timeouts. Transactions using Pay-By-Link are still processing, but may take longer than usual. Thank you for your patience as we work to resolve this issue.
Posted Apr 23, 2025 - 08:30 CDT
This incident affected: Payment processing (Ascend Pay).