US East Stratus Down

Resolved

This incident has been resolved, if you are still experiencing issues connecting to Stratus services after rebooting your devices, please reach out to Ascend Support
Posted Jul 28, 2026 - 10:02 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 28, 2026 - 09:37 CDT

Identified

We are aware of the US East region Stratus outage and are working to restore services as quickly as possible.
Posted Jul 28, 2026 - 09:29 CDT
This incident affected: Payment processing (Ascend Pay, Chase Payments) and Services (Stratus).