Phone Queues Are Down
Resolved
This incident has been resolved.
Posted Nov 22, 2023 - 08:58 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 22, 2023 - 08:47 CST
Investigating
We are currently investigating issues with our Ascend, Bookkeeping and Customer Care phone queues that leave our agents unable to log in to take your calls. You can contact us via email through help@ascendrms.com or customercare@trekbikes.com with any questions or problems you may encounter in the meantime.
Posted Nov 22, 2023 - 08:24 CST
This incident affected: Phone support (Phone Support - US).