Issue: Listen360 and Ascend HQ
Resolved
Our partners at Listen360 have resolved the issue. Both Listen360 and Ascend HQ should load properly. Thank you for your patience as this issue was resolved.
Posted Nov 07, 2023 - 07:45 CST
Investigating
We're currently investigating an issue affecting Listen360 and AscendHQ. You may experience errors with the affected components until the issue is resolved.
Posted Nov 06, 2023 - 09:15 CST
This incident affected: Services (Ascend HQ).