Ascend Pay Terminal Connectivity Issues

Resolved

We are no longer seeing terminal connection errors, if a reboot (holding the green button) does not reconnect your terminal, please reach out to Ascend Support.
Posted Apr 22, 2025 - 13:51 CDT

Update

We are continuing to monitor for any further issues.
Posted Apr 22, 2025 - 12:07 CDT

Monitoring

We are actively working to clear caches and recommend rebooting payment terminals (hold the green button) and computers to expedite the resolution process. Thank you for your cooperation and patience.
Posted Apr 22, 2025 - 10:51 CDT

Update

We are continuing to investigate this issue.
Posted Apr 22, 2025 - 09:29 CDT

Update

We are continuing to investigate this issue.
Posted Apr 22, 2025 - 09:26 CDT

Investigating

We are currently investigating delays in connecting payment terminals to Ascend, which may result in timeouts. Transactions using Pay-By-Link are still processing, but may take longer than usual. Thank you for your patience as we work to resolve this issue.
Posted Apr 22, 2025 - 09:20 CDT
This incident affected: Payment processing (Ascend Pay).