Outage: Email support (help@ascendrms.com & support@ascendrms.com)
Resolved
This incident has been resolved.
Posted Dec 01, 2023 - 09:38 CST
Identified
We've identified an issue preventing incoming emails to the Ascend support mailbox reaching our team. If you're attempting to email us, you may be unable to establish a connection until a fix is applied.

If you need help now, give us a call on 877-875-8663 or click here to troubleshoot your issue using our online resources: http://www.ascendrms.com/gethelp
Posted Nov 30, 2023 - 11:56 CST
This incident affected: Services (Email).