Outage: Phone support
Resolved
Our partners were able to resolve the issue impacting our team taking phone calls. Our lines are back up and running! Thank you for your patience as we resolved this issue.
Posted Apr 25, 2024 - 12:14 CDT
Identified
We've identified an issue preventing incoming calls to the Ascend phone support line from reaching our team. If you're attempting to call, you may be unable to establish a connection until a fix is applied.

If you need help now, send an email to support@ascendrms.com to submit a ticket or troubleshoot your issue using our online resources: http://www.ascendrms.com/gethelp. Thank you for your patience as we work with our partner to resolve this issue.
Posted Apr 25, 2024 - 11:40 CDT
This incident affected: Phone support (Phone Support - US, Phone Support - CA).