Global Outage: Phone support
Resolved
This issue has been resolved by our partner. All phone queues are operational. Thank you for your patience as the issue was addressed.
Posted Jan 19, 2024 - 10:40 CST
Identified
We've identified an issue preventing incoming calls to the Ascend phone support line from reaching our team. If you're attempting to call, you may be unable to establish a connection until a fix is applied.

If you need help now, click here to submit a ticket or troubleshoot your issue using our online resources: http://www.ascendrms.com/gethelp
Posted Jan 19, 2024 - 09:07 CST
This incident affected: Phone support (Phone Support - US, Phone Support - CA).