Degraded performance: Credit Card Integration
Resolved
Our development team has released a hotfix to address this issue. We have verified that Ascend Pay charges are now being processed correctly. We apologize for any inconvenience this caused you and your customers. Thank you for your patience.
Posted Mar 27, 2024 - 19:10 CDT
Update
Please be advised that we recommend not taking credit card payments at this time. We will update this thread as soon as we have more details.
Posted Mar 27, 2024 - 16:34 CDT
Investigating
We're currently investigating an issue affecting Ascend Pay processing within Ascend. If you're having issues with timeouts, please do not try to run the payment again. Call into support for further assistance (877-875-8663). We will update this post within an hour with further details. Thank you for your patience.
Posted Mar 27, 2024 - 16:27 CDT
This incident affected: Services (Stratus).