Comcast Partial Outage
Resolved
We have heard from a number of retailers that Comcast services have been restored and should not be presenting an issue at this time.

If you are still experiencing difficulties with Ascend cloud services down, credit card processing issues, or phone problems; we recommend rebooting your modem and router. If the problem persists, please reach out to us at Ascend Support or your internet service provider for additional assistance.
Posted Jun 17, 2023 - 13:00 CDT
Monitoring
We have received multiple reports from Comcast users across the US reporting poor connectivity with their internet, resulting in Ascend cloud services down, credit card processing issues, and phone problems.

Comcast is aware of the issue but we do not have an ETA for a resolution from them on this, but are monitoring the situation.
Posted Jun 17, 2023 - 10:48 CDT
This incident affected: Payment processing (Chase Payments, Klarna - US), Phone support (Phone Support - US), and Services (Multi-store, Stratus).