Degraded performance: Chase Payments (Possibly only California)
Resolved
We have stopped receiving calls on this issue and believe Chase has resolved whatever was at fault. Please call in if you continue having errors processing cards. Thank you.
Posted May 03, 2023 - 07:48 CDT
Identified
We're currently investigating an issue affecting Chase payment processing in Ascend. If you're actively integrated with Chase Payments, you may experience errors until the issue is resolved. This appears to be on the Chase end, specifically in California, but we will update this page when we hear any updates. Thank you for your patience.
Posted May 02, 2023 - 14:45 CDT
This incident affected: Payment processing (Chase Payments).