US Ascend Pay - Processing Issue

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 10:37 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 21, 2025 - 09:56 CDT

Investigating

We are currently investigating an issue where Ascend Pay terminals are generating errors and having issues processing payments. Our development team is working to identify the issue and resolve it as quickly as possible. Pay by Link transactions are reporting to process at a higher success rate.
Ascend Stuck? Hover over the icon on the taskbar and look to see if there's a little window Ascend wants you to close behind the screen.
Posted Aug 21, 2025 - 09:25 CDT
This incident affected: Payment processing (Ascend Pay).