Trek B2B Purchase Order Syncing Down
Resolved
We have verified that our fixes resolved the issue.

Please note, there are some products which still display on Trek B2B as orderable with a future release date but show as purple in Ascend. We are waiting on a fix from our B2B team for these products. This will hopefully come out within the next few weeks.

Until then, if you come across one of these products, please hold the orders for rep review so that you can add them from the B2B side.

Thank you for your patience as we resolve these issues.
Posted Apr 11, 2024 - 08:01 CDT
Monitoring
We've resolved the issue impacting this integration. We will monitor to make sure everything works accordingly. We will update this post on 3/27 once we've verified things are working as planned for a week. Please call into support if you do see any issues.

Please note, for existing orders:

If they were created in Ascend:
-Status likely says "Submitted (Pending)". If so, clicking the Sync button will re-pull the whole order and it will then be up-to-date.

For those created in HQ or B2B:
-The order may or may not have been pulled into the client. If pulled in, then it may be in part or in full. It will be resolved either when receiving via the Receiving Wizard or by creating a dummy order with a random product and the B2B vendor order number, saving the order (NOT Apply), reopening the order, then clicking the Sync button.
-Note: Orders created in HQ/B2B that are un-synced or incompletely synced to the client will potentially impact Reorder Items and Special Order Items if additional Trek orders are created before those products are received.
Posted Mar 19, 2024 - 13:56 CDT
Investigating
We're currently investigating an issue affecting Trek B2B integration. You may experience errors with Purchase Order Syncing until the issue is resolved.
Posted Mar 15, 2024 - 17:20 CDT
This incident affected: Third-party integrations (Trek).