Outage: US Email support
Resolved
This issue has been resolved. Thank you for your patience as we worked with Microsoft to ensure your messages to us were delivered.
Posted Nov 15, 2023 - 08:05 CST
Identified
We've identified an issue with Microsoft preventing emails from reaching the US Support Team. If you're attempting to email, responses will be delayed until Microsoft can help us fix the issue.

If you need help now, give our team a call at 877.875.8663. Our phone lines are open and we're ready to assist!
Posted Nov 10, 2023 - 08:57 CST
This incident affected: Services (Email).