Outage: Phone support
Resolved
Our phone system provider was able to resolve the issue impacting us. Phone support is fully operational again. Thank you for your patience as we resolved this issue.
Posted May 20, 2023 - 14:50 CDT
Identified
We've identified an issue preventing incoming calls to the Ascend phone support line from reaching our team. If you're attempting to call, you may be unable to establish a connection until a fix is applied.

If you need help now, click here to submit a ticket or troubleshoot your issue using our online resources: http://www.ascendrms.com/gethelp
Posted May 19, 2023 - 17:05 CDT
This incident affected: Phone support (Phone Support - US, Phone Support - CA).