Outage: Phone support

Resolved

This incident has been resolved. Thank you for your patience during this outage.
Posted Jul 16, 2025 - 10:38 CDT

Identified

We've identified an issue preventing incoming calls to the Ascend phone support line from reaching our team. If you're attempting to call, you will be unable to establish a connection until a fix is applied.

If you need help now, email us at support@ascendrms.com to submit a ticket or troubleshoot your issue using our online resources: http://www.ascendrms.com/gethelp
Posted Jul 16, 2025 - 08:27 CDT
This incident affected: Phone support (Phone Support - US, Phone Support - CA).