Degraded performance: Ascend HQ
Resolved
This issue has been resolved, you can access your Ascend HQ normally.
Posted Jul 20, 2021 - 15:46 CDT
Investigating
We're currently investigating an issue affecting one or more of our online services that is disrupting Ascend functionality. You may experience errors with the affected component(s) until the issue is resolved.
Posted Jul 20, 2021 - 15:04 CDT
This incident affected: Services (Ascend HQ).